Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fahren mit 2 Autos pro Spur
#61
Hi Michaelo,

Danke für die Blumen.
nein ich hab nicht mehr weitergemacht, die Bahn ist wieder abgebaut. Aber die Schaltung hat super funktioniert, das Fahrverhalten war um Klassen besser, besonders beim Langsam- und Anfahren. Nur der L 293 raucht gerne mal ab, da wäre ein belastbareres IC sicher noch von Vorteil.
Zitieren
#62
Finde ich interessant, das Thema. Daher wäre für mich und bestimmt für viele andere auch ne DIY Anleitung/Zusammenfassung super.
Zitieren
#63
Im Prinzip steht alles hier in dem Post schon drin!
Du brauchst nur einen Arduino, ein L293 (Motorsteuerungschip) ein Bastelbrett ein paar Kabel. Die Software ist Arduino Block und der Code steht auch weiter vorne! Falls du noch die genaue Verdrahtung brauchst, die könnte ich noch irgendwo haben.
Zitieren
#64
Hallo, der Fahrtregler mit dem Arduino funktioniert sehr gut. Allerdings geht ziemlich Spannung verloren an dem angeschlossenen Motortreiber (bis zu 4 Volt!). Das bedeutet, daß man für Faller-Chassis ein Netzteil (stabilisiert) mit mindestens 15 V einsetzen muss, mit einem 12 V-Netzteil werden die wenigsten fahren können.
So sieht das dann bei mir aus:

https://www.youtube.com/watch?v=R3xJaZfu...dex=4&t=0s

oder so:

https://www.youtube.com/watch?v=Zn19CwB9...3V&index=2

Die ganze Steuerung z.B. für das Schaufensterprojekt passt in ein kleines Gehäuse:

   

Hier noch einer der Darsteller:

    LKW - ursprünglich wahrscheinlich Matchbox
    Eigenbau-Chassis
    Diode für Halbwelle und Kondensator zur Entstörung

Mein Fazit: Der Versuch mit dem Arduino lohnt sich auf jeden Fall !

Hubert
Zitieren
#65
Hallo Hubert, hallo zuassammen,

willkommen zurück Big Grin .

Mir sind auch noch Mal möglicherweise geeignete Motortreiber über den Weg gelaufen: BD6222HPF (18V/2A) und L6203 (48V/5A).

Dann gibt es auch noch Motorshields für den Arduino, die passen könnten.
ciao michaelo
... und wer zuletzt aufgibt gewinnt.
Zitieren
#66
Für alle, die sich nicht vorstellen können, wie so ein Regler aussieht, hier mal ein paar Bilder:

          

Unten rechts ist die Steckbuchse für ein Universalnetzteil (z.B. wie kürzlich welche in der Rubrik "Biete" angeboten wurden). An den 4 freien Schraubklemmen wird die Fahrbahn angeschlossen.
Das rechte Bild zeigt die einzelnen Ebenen, sie werden einfach nur zusammengesteckt. - Jetzt noch ein schönes Gehäuse drum, und fertig.
Ich finde, das ist schön kompakt, Grundfläche etwa 5,5 x 7 cm, Höhe insgesamt auch 7 cm.
Wenn man eine höhere Spannung als 12 V verwendet, müsste man noch einen Festspannungsregler 5 V einbauen und den Arduino damit versorgen.
Die Kosten, je nachdem wo man einkauft, etwa ab 20 Euro.
Verwendbare Sketche für den Arduino wurden ja weiter vorn schon besprochen.

Nachtrag: An den 4 freien Schraubklemmen werden die beiden Fahrspuren angeschlossen. Das rote Kabel ist die 12 V+ Leitung vom Netzteilanschluß zum L293.
Der Festspannungsregler ist nicht unbedingt nötig, der Arduino verkraftet angeblich bis zu 20 V.

Auf dem 2. Bild war ein Fehler! Die 12 V werden am PIN 8 der Treiberchips angeschlossen - siehe rote Linie auf dem Bild.
Zitieren
#67
Guten Abend an alle Arduino Spezialisten,

https://www.ebay.de/itm/Arduino-UNO-R3-k...SwgNFb4H7W
geht der auch , oder sollte es der originale sein?

@Hubert

Angeregt durch deine Litzenschleifer hab ich diese Reparatur probiert.
   
nachher:
   

laufen spitze.

Grüße
Lothar
Zitieren
#68
Hallo Lothar,
wenn du die Schleifer mit Entlötlitze verwendest, solltest du diese vor dem Verlöten möglichst flachklopfen.
Freut mich, wenn du deine abgefahrenen Schleifer auf diese Art weiterverwenden kannst.

Zum Arduino:
Ich denke, den verlinkten kannst du verwenden. Ich verwende auch keine Originale.
Kannst dir auch gleich den Motortreiber dazubestellen:
https://www.ebay.de/itm/L293D-Motor-Trei...Swcs1b4K~f

Sinnvoll ist auch dieses Shield:
https://www.ebay.de/itm/Arduino-Uno-Prot...SwHhRb5H1~
Da kannst du evtl. gleich deine Potis draufmontieren und kannst alle drei Shields einfach zusammenstecken, ähnlich wie ich es in den Bildern weiter oben gezeigt habe.

Du kannst auch diesen Motortreiber nehmen:
https://www.ebay.de/itm/L298N-Motortreib...SwezRb4LCo
Der hat etwas mehr Power, aber dafür kannst du ihn nicht einfach draufstecken. Dann bestellst du am besten gleich noch die Kabel dazu:
https://www.ebay.de/itm/40p-10cm-Jumper-...1800241123

Ja, dann fehlen eigentlich nur noch die Potis zur Geschwindigkeitsregelung. Ich habe diese verwendet:
https://www.conrad.de/de/p/potentiometer...38015.html

Ein passendes USB-Kabel hast du hoffentlich. Falls nicht, kannst du es auch gleich mitbestellen:
https://www.ebay.de/itm/USB-2-0-Kabel-A-...SwfMlb3x9V

Kümmere dich aber vor dem Bestellen darum, ob es für die Teile Anleitungen gibt (möglichst in deutsch), damit du dann nicht raten musst, welche Anschlüsse du verwenden musst.

Ja, dann fehlt noch die Software auf deinem PC. Nennt sich Arduino IDE und kann kostenlos heruntergeladen werden. Wenn du alles beisammen hast, melde dich nochmal, dann kann ich dir auch beim Programm helfen - ist nicht schwer.

Gruß
Hubert
Zitieren
#69
Danke Hubert, 
für die ausführliche Antwort. Brauch ich dann für die Motortreiber nur einen oder für jede Spur einen?

Wollte eigentlich das:
https://www.ebay.de/itm/Protoshield-f%C3...1438.l2649
und das:
https://www.ebay.de/itm/L293D-4-Kanal-Ha...1438.l2649

Verwenden und dann zusammenstecken wie in deinen Bildern.
Potis hab ich noch in einer Kiste.

Schönes Wochenende

Lothar
Zitieren
#70
Hallo Lothar,
ja, die Teile kannst du auch verwenden. Was noch fehlt, sind die Klemmanschlüsse für den Anschluss der Fahrbahn.
Motortreiberchip brauchst du nur einen, damit kannst du normalerweise 2 Motoren anschließen mit Vorwärts- und Rückwärtslauf, oder eben 4 von unseren Chassis, wenn sie mit Dioden/Selenplatten entsprechend ausgerüstet sind.

Über das Verlöten des L293 schreibe ich extra nochmal was in den nächsten Tagen.

Gruß
Hubert

Nachtrag: So habe ich die Ebenen aufgebaut:

          

Die 12 V-Leitung habe ich unten am Arduino am Netzteileingang angelötet
Zitieren
#71
Perfekt,

die ersten Teile sind bestellt, Code ist ausgedruckt und Schaltplan von 72Sonett auch.
Arduino IDE ist runtergeladen. Jetzt muss ich nur noch warten bis die Teile da sind.

Schöne Grüße
Lothar
Zitieren
#72
Hallo Lothar
die beiden Codes, die weiter vorn veröffentlicht sind, kannst du beide mal probieren. Ich habe aber festgestellt, daß sie nicht optimal sind. da dran bastle ich derzeit.
Ok - die Codes funktionieren schon, aber da ist ein delay (=Pause) im Programm, und das führt zu einem etwas ruckeligen Verhalten bei langsamer Fahrt und zum Flackern der Beleuchtung. Das versuche ich noch wegzubekommen.

Ich habe jetzt auch mal einen Versuch gemacht mit einem Flachankermotor, und der fährt eigentlich auch recht langsam, durchaus brauchbar für Stadtverkehr. Ab einer Geschwindigkeit von ca. 10 cm/s fährt das Chassis recht sauber und fährt auch wieder alleine los, wenn man mal kurz den Strom unterbricht (z.B. Stoppstelle). Das ist durchaus brauchbar.
Ich hab zu diesem Versuch auch mal ein Video gemacht, es wird in ein paar Minuten hochgeladen sein.
Natürlich habe ich wieder meine präparierte Fahrbahn genommen und Litzenschleifer, weil ich damit wirklich sehr gute Erfahrungen gemacht habe und nicht mehr drauf verzichten möchte.

- Was man natürlich bedenken muß bei diesem Halbwellenbetrieb: Es ist kein Vergleich zum Digitalbetrieb. Dort hat man die Lastregelung, und die ist Gold wert, vor allem wenn man Steigungen und Gefälle auf der Anlage hat. Aber das muss jeder selbst ausprobieren ...

Hier also das Video:

https://youtu.be/dWQh_7gX-QM

Man sieht in dem Video auch ganz gut das Problem mit der Haftreibung. Das Motorritzel fängt schon an zu zittern, schafft es aber nicht, loszufahren. Erst mit etwas mehr Power geht es, aber dann macht es gleich einen kleinen Satz vorwärts.

Gruß
Hubert
Zitieren
#73
Hallo Junx,

heute ist der Arduino angekommen. Gleich ne Frage, woran erkenne ich, ob der mit 3,3 V oder 5 V arbeiten will.
Über USB hab ich schon den "Blinker" modifiziert und getestet. Schnittstelle Stimmt und Software funzt auch.

@ Hubert: aber soooo langsam will ich doch nicht fahren. der stick-slip Effekt ist mir wohl bewusst.
Meine Idee war, über das Programm den Regelbereich ein zustellen. Soll heißen min. und max. Geschwindigkeit zu definieren
und über die Potis nur innerhalb dieser Grenzen zu regeln. Dann wäre der Start ja immer oberhalb der Haftreibung.
Dazu muss ich mich aber erst noch ein "wenig" einarbeiten

Grüße
Lothar
Zitieren
#74
Hallo Lothar
wünsche dir einen guten Start.

Der Arduino arbeitet mit 5 V, da dran kannst du nix ändern. Der 3,3 V-Anschluß ist für den Betrieb anderer Module, die diese Spannung brauchen (z.B. RFID-Lesemodul).

Betreiben kannst du den Arduino mit USB, wenn deine Versuche nicht mehr als 5 V brauchen.

Du wirst aber eine höhere Spannung brauchen (12 - 15 V), wofür du den Netzteilanschluß brauchst. (USB vorher ausstecken). Keine Sorge, der eingebaute Spannungsregler versorgt den Arduino weiterhin mit 5 V.

Jetzt wünsche ich dir erst mal viel Spaß.

Hubert
Zitieren
#75
Hallo, jetzt habe ich mit dem Arduino-Regler noch ein wenig gespielt.
Diesmal habe ich auch 2 Flachanker mit dazugenommen.

               

Der Einfachheit halber habe ich bei den Flachankern isolierte Schleifer und Dioden verwendet anstatt der Selenplatte.
Der eingebaute Kondensator (47µF) macht die Chassis erstaunlich schnell, fast wie normaler Gleichstrom.
Und wie man sieht, bei den Eigenbauten das ganz normale Blomo-Getriebe 1:5 beim Porsche bzw. wegen Platzmangel bei GT 40 ein 2:10.
Die beiden Eigenbauten sind, jedenfalls in den Kurven, etwas schneller als die Flachanker, wahrscheinlich durch den tieferen Schwerpunkt.

siehe auch:
https://youtu.be/esNorKItACY
Zitieren
#76
Hallo Hubert,

Mal wieder ein feines Filmchen Smile .

Genau genommen konterkariert der Kondensator die Idee von Maxhoe, die Autos mit PWM-Regelung langsamer fahren zu lassen. Vor Allem weil wir ja schnell sowieso können. Aber Rennen sieht auch gut aus  Cool .
ciao michaelo
... und wer zuletzt aufgibt gewinnt.
Zitieren
#77
Hallo
die Idee von Martin war doch, die Fahrzeuge mit PWM anzusteuern, um damit in erster Linie Stadtbahnbetrieb zu ermöglichen.
Das funktioniert auch, mit einigen Einschränkungen, zu denen ich gleich komme.
Mein Versuch mit der Achterbahn war ja nur mal die Überlegung, ob man mit der PWM-Halbwelle auch z.B. Verfolgungssrennen fahren könnte. Und das klappt auch. - Ich habe es noch nicht probiert, aber ich denke, daß man die Handregler mit Dioden in die Zuleitungen einbauen kann und dann damit die Geschwindigkeit der Fahrzeuge regeln kann.
Der Einbau des Kondensators erhöht die Motorleistung, egal ob man schnell oder langsam fährt.

Nun noch zum Stadtbahnbetrieb mit PWM:
Ohne Zweifel kann man damit eine Geschwindigkeit einstellen, die dem Stadtbetrieb angemessen ist. Vorausgesetzt, es gibt auf der Anlage keine Steigungen oder Gefälle. Für solche Anlagen eignen sich nur Chassis mit den entsprechenden Getrieben, also Zinkmotor oder Stadtgetriebe. Die normalen Flachanker werden an Steigungen extrem langsam, manche bis zum Stillstand, und im Gefälle so schnell, daß sie die nächste Kurve nicht schaffen. Hier fehlt die Lastregelung, wie man sie von Digitaldecodern kennt.

Alle von mir getesteten Flachanker haben auch die Angewohnheit, daß sie immer schneller werden. (Dieses Verhalten bemerkte ich übrigens auch bei T-Jet und AFX) Damit ist ein automatischer Betrieb nur schwer möglich. Dieses Verhalten kann man auch beim normalen Gleichstrom- und Halbwellenbetrieb beobachten. Ich vermute, daß es vom Temperaturverhalten der Motoren kommt. Dieses Verhalten konnte ich auch auf der Rennstrecke beobachten, nur merkt man es da oft nicht, weil man ja ohnehin ständig am Nachregeln ist.

In diesem Zusammenhang ist auch das Anfahrverhalten z.B. an einer Ampel problematisch. Es sieht einfach doof aus, wenn sich ein Fahrzeug an einer grünen Ampel in Bewegung setzt, aber erst nach etwa 30 - 40 cm eine halbwegs passable Geschwindigkeit erreicht und dann vielleicht an einer Steigung schon wieder im Kriechgang fährt, um dann beim nächsten Gefälle mit Höchstgeschwindigkeit hinuterzurasen.

Mein Fazit: Der PWM-Regler ist mit Sicherheit eine Verbesserung gegenüber dem Halbwellenschaltgerät, wer aber wirklich automatischen Betrieb auf der Anlage plant, kann dies nur mit Digitalsteuerung erreichen.

Gruß
Hubert
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste